A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- adjustForSelfIntersection
- Type: System Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
- suppressHooks
- Type: System Boolean
Identifies if the chain will include hooks curves.
- suppressBendRadius
- Type: System Boolean
Identifies if the connected chain will include unfilleted curves.
- barPositionIndex
- Type: System Int32
The bar index.
Return Value
The centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.Remarks
This method will return the centerline curves for bar at barPositionIndex even if this bar isn't included. The curves are in the final position. The BarPositionTransform (representing the relative position of any individual bar in the set - a translation along the distribution path) and MovedBarTransform (representing the movement of the bar relative to its default position along the distribution path) will be applied to the returned curves.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |