GetPointCloudScanOverrideSettings Method (ElementId)


Gets scan override settings assigned to the whole PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public PointCloudOverrideSettings GetPointCloudScanOverrideSettings(
	ElementId elementId
)
Visual Basic
Public Function GetPointCloudScanOverrideSettings ( _
	elementId As ElementId _
) As PointCloudOverrideSettings
Visual C++
public:
PointCloudOverrideSettings^ GetPointCloudScanOverrideSettings(
	ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB ElementId
Id of the overridden element.

Return Value

The override settings assigned to the element, if present, or a default override settings if nothing was found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also