GetLightSourceTransform Method


Returns a Transform value for the transform of light source.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public Transform GetLightSourceTransform()
Visual Basic
Public Function GetLightSourceTransform As Transform
Visual C++
public:
Transform^ GetLightSourceTransform()

Return Value

The light source transform.

Remarks

When the user moves or rotates the light source in family editor, the returned Transform gets changed accordingly.

See Also