Distance Property


Represents the distance from either the top or base of the wall for horizontal sweeps, or the parameter along the wall's path curve for vertical ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
	Get
	Set
Visual C++
public:
property double Distance {
	double get ();
	void set (double value);
}

Field Value

DistanceMeasuredFrom determines where the measurement starts from, depending on the orientation of the sweep. If the sweep or reveal is vertical, this distance is equal to the parameter along the wall's path curve.

See Also