Stores the value of the field in the entity.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- field
- Type: Autodesk.Revit.DB.ExtensibleStorage Field
The field to update.
- value
- Type: FieldType
Type Parameters
- FieldType
- The type of the field
Remarks
The template parameter must match the type of the field (specified when creating the Schema) exactly; this method does not perform data type conversions. The types for containers are IList for arrays and IDictionary for maps.
Note that when string values are specified as map keys, they are case-insensitive.
This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid. |
Autodesk.Revit.Exceptions ArgumentException | Requested type does not match the field type. |
Autodesk.Revit.Exceptions ArgumentException | For floating-point fields, use the overload taking a ForgeTypeId parameter. |
Autodesk.Revit.Exceptions ArgumentException | This field's subschema prevents writing. |
Autodesk.Revit.Exceptions ArgumentException | Invalid floating-point value. |
Autodesk.Revit.Exceptions ArgumentException | String is too long; exceeds max length of 16mb characters. |