Flips the ends of the structural framing element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyInstance
- Type: Autodesk.Revit.DB FamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete.
Remarks
Only ends of non-concrete structural framing element like beam and brace can be flipped and only in case if it is a line, arc or ellipse element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input familyInstance is concrete or is not a line, arc or ellipse element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The input familyInstance is not of a structural framing category. |