GetCurrentSolutionPartTypeIds Method


Returns set of fabrication part types that are used in the currently selected solution.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017

Syntax

C#
public ISet<ElementId> GetCurrentSolutionPartTypeIds()
Visual Basic
Public Function GetCurrentSolutionPartTypeIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetCurrentSolutionPartTypeIds()

Return Value

The set of ElementIds.

See Also