GetCamera Method


Gets the camera corresponding to the Revit view where rendering takes place.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017

Syntax

C#
public static Camera GetCamera()
Visual Basic
Public Shared Function GetCamera As Camera
Visual C++
public:
static Camera^ GetCamera()

Return Value

The camera.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.

See Also