Creates a new instance of Structural Section Round Bar shape with the associated set of parameters, used to attach to structural element.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- diameter
- Type: System Double
Pipe Diameter.
- centroidHorizontal
- Type: System Double
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: System Double
Distance from centroid to the upper extremites along vertical axis.
- principalAxesAngle
- Type: System Double
Rotation angle between the principal axes and cross section reference planes.
- sectionArea
- Type: System Double
Cross section area.
- perimeter
- Type: System Double
Painting surface of the unit length.
- nominalWeight
- Type: System Double
Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
- momentOfInertiaStrongAxis
- Type: System Double
Moment of Inertia about main strong axis (I).
- momentOfInertiaWeakAxis
- Type: System Double
Moment of Inertia about main weak axis (I).
- elasticModulusStrongAxis
- Type: System Double
Elastic section modulus about main strong axis for calculation of bending stresses.
- elasticModulusWeakAxis
- Type: System Double
Elastic section modulus about main weak axis for calculation of bending stresses.
- plasticModulusStrongAxis
- Type: System Double
Plastic section modulus in bending about main strong axis (Z, Wpl)
- plasticModulusWeakAxis
- Type: System Double
Plastic section modulus in bending about main weak axis.
- torsionalMomentOfInertia
- Type: System Double
Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
- torsionalModulus
- Type: System Double
Section modulus for calculations of torsion stresses (Ct)
- warpingConstant
- Type: System Double
Warping constant (Cw, Iomega, H)
- shearAreaStrongAxis
- Type: System Double
Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
- shearAreaWeakAxis
- Type: System Double
Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).