The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The id must be valid for use as a preview view (check DocumentPreviewSettings.IsViewIdValidForPreview()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs().Remarks
If this id is set, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was null |