GetLoadRequestId Method


Returns the load operation GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public Guid GetLoadRequestId()
Visual Basic
Public Function GetLoadRequestId As Guid
Visual C++
public:
Guid GetLoadRequestId()

Return Value

The load operation GUID.

Remarks

This Id uniquely identifies the load request. IExternalResourceServers can use it as a key to store and retrieve information (such as errors) that is relevant to a specific load operation.

See Also