IsLargeGeometryAllowed Method


Returns if large geometry is allowed for path of travel creation or not.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public bool IsLargeGeometryAllowed()
Visual Basic
Public Function IsLargeGeometryAllowed As Boolean
Visual C++
public:
bool IsLargeGeometryAllowed()

Remarks

The return value is based off the current setting for the AllowLargeGeometry Property as follows:
  • If it is set to Prompt, then prompts the user to continue or not, if no ui is present, returns false.
  • If it is set to DisAllaow, returns false.
  • If it is set to Allow, returns true.

See Also