OriginatingElementDescription Property


The description for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public string OriginatingElementDescription { get; }
Visual Basic
Public ReadOnly Property OriginatingElementDescription As String
	Get
Visual C++
public:
property String^ OriginatingElementDescription {
	String^ get ();
}

Remarks

Surface and Opening elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name): (Family Type)[Element Id]

Sample: Basic Wall: Cast Concrete Wall 12" [49749]

See Also