Insert Method


Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public virtual bool Insert(
	string key,
	Category item
)
Visual Basic
Public Overridable Function Insert ( _
	key As String, _
	item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
	String^ key, 
	Category^ item
)

Parameters

key
Type: System String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also