GetAnalyticalPropertyData Method


Gets the electrical analytical node property data, a null reference ( Nothing in Visual Basic) if not available.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public AnalyticalDistributionNodePropertyData GetAnalyticalPropertyData()
Visual Basic
Public Function GetAnalyticalPropertyData As AnalyticalDistributionNodePropertyData
Visual C++
public:
AnalyticalDistributionNodePropertyData^ GetAnalyticalPropertyData()

Return Value

The electrical analytical node property data.

Remarks

These types have special data:
  • Bus
  • TransferSwitch
  • EquipmentLoad

See Also