IsFlippedOnFace Method (Face)


Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021

Syntax

C#
public bool IsFlippedOnFace(
	Face face
)
Visual Basic
Public Function IsFlippedOnFace ( _
	face As Face _
) As Boolean
Visual C++
public:
bool IsFlippedOnFace(
	Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB Face
The face with respect to which the direction is considered. Must belong to the edge.

Return Value

true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.

Remarks

Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the specified face is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when the specified face is not one of the faces for this edge.

See Also