Returns the RouteAnalysisSettings element for a given document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- cda
- Type: Autodesk.Revit.DB Document
The document for which to get the RouteAnalysisSettings element.
Return Value
Returns the RouteAnalysisSettings element in project documents or a null reference ( Nothing in Visual Basic) for family documents
.Remarks
Project documents have a RouteAnalysisSettings element, one per document. Family documents do not have RouteAnalysisSettings elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |