Sets a group of user-created worksets to close.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetsToClose
- Type: System.Collections.Generic IList WorksetId
The group of user-created worksets to close. Non-user-created worksets and invalid workset ids will be ignored.
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.CloseAllWorksets will set these worksets to be explicitly closed. If all worksets are set to close, the configuration will be unchanged. Worksets other than the inputs are unaffected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |