Sets the default family type id for the given family category.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyCategoryId
- Type: Autodesk.Revit.DB ElementId
The family category id.
- familyTypeId
- Type: Autodesk.Revit.DB ElementId
The default family type id.
Examples

private void SetDefaultTypeFromDoor(Document document, FamilyInstance door)
{
ElementId doorCategoryId = new ElementId(BuiltInCategory.OST_Doors);
// It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
// Trying to set a non-qualifying default type will cause an exception
if (door.Symbol.IsValidDefaultFamilyType(doorCategoryId))
{
document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id);
}
}

Private Sub SetDefaultTypeFromDoor(document As Document, door As FamilyInstance)
Dim doorCategoryId As New ElementId(BuiltInCategory.OST_Doors)
' It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
' Trying to set a non-qualifying default type will cause an exception
If door.Symbol.IsValidDefaultFamilyType(doorCategoryId) Then
document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id)
End If
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The family type id familyTypeId is invalid for the give family category familyCategoryId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |