LineLightShape Constructor (Double)


Creates a line light shape object with the given emit length.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public LineLightShape(
	double emitLength
)
Visual Basic
Public Sub New ( _
	emitLength As Double _
)
Visual C++
public:
LineLightShape(
	double emitLength
)

Parameters

emitLength
Type: System Double
The emit length as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also