GetPolyloops Method


Gets the collection of planar polygons describing the surface geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public IList<Polyloop> GetPolyloops()
Visual Basic
Public Function GetPolyloops As IList(Of Polyloop)
Visual C++
public:
IList<Polyloop^>^ GetPolyloops()

Return Value

The collection of polygons describing the surface geometry.

Remarks

A collection of polyloops (planar polygons) describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).

See Also