FreeFormElement Class


A Free Form Element that contains non-parametric geometry created from an input solid outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public class FreeFormElement : GenericForm
Visual Basic
Public Class FreeFormElement _
	Inherits GenericForm
Visual C++
public ref class FreeFormElement : public GenericForm

Remarks

The element can participate in joins and void cuts with other combinable elements.

Inheritance Hierarchy

See Also