LineStyle Property


The line style that determines how the lines of a hidden segment display at the point where the segments cross.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public ElementId LineStyle { get; set; }
Visual Basic
Public Property LineStyle As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ LineStyle {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The line style is invalid for hidden line display.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also