Connects placeholders that looks like Cross connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- connector1
- Type: Autodesk.Revit.DB Connector
The first end connector of placeholder to be connected to the second.
- connector2
- Type: Autodesk.Revit.DB Connector
The second end connector of placeholder to be connected to the first.
- connector3
- Type: Autodesk.Revit.DB Connector
The third end connector of placeholder to be connected to the forth.
- connector4
- Type: Autodesk.Revit.DB Connector
The fourth end connector of placeholder to be connected to the third.
Return Value
True if connection succeeds, false otherwise.Remarks
The placeholders may or may not have physical connection. However a) The ends of four connectors should intersect at same point; b) the first and second placeholders should be collinear each other; c) the third and fourth placeholders should be collinear each other and d) the third and fourth should have intersection with first or second placeholder. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |