Creates a constraint for the end handle of the rebar. This constraint will be set preferred after the API execution is finished successfully.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetReferences
-
Type:
System.Collections.Generic
IList
Reference
The references to which the rebar handle will be constrained. Will throw exception if it's empty or if it's anything but Face(s) from a structural that can host rebar.
- isConstraintToCover
-
Type:
System
Boolean
If true the RebarConstraintType will be set to ToCover, otherwise RebarConstraintType will be set to FixedDistanceToHostFace.
- offsetValue
-
Type:
System
Double
The distance from references to the rebar handle.
Return Value
Returns true if a start constraint can be created with the given references, false otherwise. The reference should be faces from structurals that can host rebar.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |