CreateEqualsRule Method (ElementId, String)


Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateEqualsRule(
	ElementId parameter,
	string value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
	parameter As ElementId, _
	value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
	ElementId^ parameter, 
	String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System String
The user-supplied string value against which values from the document will be compared.

Return Value

Created filter rule object.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also