Finds the source fabrication configuration on disk which matches the input fabrication configuration.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fabricationConfiguration
- Type: Autodesk.Revit.DB FabricationConfigurationInfo
The fabrication configuration to match.
Return Value
The matching source fabrication configuration.Remarks
Fabrication configuration is matched by configuration GUID and version. The GUIDs are required to be the same. For version, we first try to match the version exactly. If Revit cannot find an exact match, then it looks for the closest version later than the input configuration, then the closest earlier version.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |