Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- style
- Type: Autodesk.Revit.UI.Selection PickBoxStyle
Specifies the value that controls the style of the pick box.
- statusPrompt
- Type: System String
The message shown on the status bar.
Return Value
The picked box that contains two XYZ points.Remarks
The method starts an editor and returns when it finishes. Returns a PickedBox that contains two XYZ points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the style is not a recognized value. |
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the argument statusPrompt is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode. |