SetPath Method (String)


Update the path of the file that specifies the image to be used.

The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020

Syntax

C#
public void SetPath(
	string path
)
Visual Basic
Public Sub SetPath ( _
	path As String _
)
Visual C++
public:
void SetPath(
	String^ path
)

Parameters

path
Type: System String
The file path that specifies the image to be used.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also