SketchId Property


Sketch associated to this Revit element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public ElementId SketchId { get; }
Visual Basic
Public ReadOnly Property SketchId As ElementId
	Get
Visual C++
public:
property ElementId^ SketchId {
	ElementId^ get ();
}

Remarks

Analytical Element may not have a valid sketch. To edit the sketch profile you can use SetOuterContour(CurveLoop) or [!:Autodesk::Revit::DB::SketchEditScope] .

See Also