Creates a new linear dimension object using the specified dimension style.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the dimension is to be visible. The view must be a null reference ( Nothing in Visual Basic) if the document is in [!:Autodesk::Revit::DB::SketchEditScope] .
- line
- Type: Autodesk.Revit.DB Line
The line drawn for the dimension.
- references
- Type: Autodesk.Revit.DB ReferenceArray
An array of geometric references to which the dimension is to be bound.
- dimensionType
- Type: Autodesk.Revit.DB DimensionType
The dimension style to be used for the dimension.
Return Value
If successful a new dimension object, otherwise a null reference ( Nothing in Visual Basic) .Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when references are not geometric references. |