Area Property


The area for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2012

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
	Get
Visual C++
public:
property double Area {
	double get ();
}

Remarks

If the space is created with the mode 'Use Rooms or Spaces', this value is the enclosed area measured by interior bounding surfaces. Otherwise, this value is measured by the center plane of walls and the top plane of roofs and floors.

See Also