Returns the signed volume of this solid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The real number equal to the signed volume of this solid.Remarks
Revit attempts to compute the volume analytically, if possible. If an analytical solution is not possible, it uses tessellated faces to calculate a reasonable approximation for the volume. The calculated volume may be slightly underestimated or overestimated if curved surfaces are present.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed. |