Sets the ID of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vendorId
- Type: System String
The vendor id.
Return Value
The SchemaBuilder object may be used to add more settings.Remarks
This method throws an ArgumentException if the given vendor ID string is not valid. To understand the validity requirements for vendor ID strings, see the documentation for the ESSchemaBuilder method vendorIdIsValid(). Since vendor IDs are not case sensitive, the string will be converted to upper case before it is stored in the schema.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The vendorId is invalid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The SchemaBuilder has already finished building the Schema. |