GetReferences Method


Returns the references that are currently selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public IList<Reference> GetReferences()
Visual Basic
Public Function GetReferences As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferences()

Return Value

The collection containing the selected references.

Remarks

The references can be an element or subelement in the host or a linked document.

See Also