Validates whether the specified element id is a material element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pElem
- Type: Autodesk.Revit.DB Element
An element which will be applied the material
- materialId
- Type: Autodesk.Revit.DB ElementId
The element id to be checked.
Return Value
True if the element a material element or invalidElementId, which means take material from category, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |