For shape driven rebar returns all possible RebarConstraints that could be used for a specified RebarConstrainedHandle.
For free form rebar will return an empty list.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.Structure RebarConstrainedHandle
The RebarConstrainedHandle for which constraint candidates are sought.
Return Value
A collection of RebarConstraintsExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |