TypeId Property


Specifies the ElementId of the labels' type. The default value is InvalidElementId. in this case, CreateSet(Alignment, View, AlignmentStationLabelSetOptions) will throw an exception.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public ElementId TypeId { get; set; }
Visual Basic
Public Property TypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

Recommended types can be found using IsRecommendedTypeForSet(Element) Other valid types can be found using IsValidType(Element) .

See Also