Item Property


Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public virtual Category this[
	string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
	key As String _
) As Category
	Get
	Set
Visual C++
public:
virtual property Category^ Item[String^ key] {
	Category^ get (String^ key);
	void set (String^ key, Category^ value);
}

Parameters

key
Type: System String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also