Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filename
- Type: System String
The fully qualified filename of the Family file, usually ending in .rfa.
- familyLoadOptions
- Type: Autodesk.Revit.DB IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
- family
- Type: Autodesk.Revit.DB Family %
A reference to the family that was loaded if successful, otherwise Nothing.
Return Value
True if the entire family was loaded successfully into the project, otherwise False.Remarks
Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when filename is a null reference ( Nothing in Visual Basic) or empty. |
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument "familyLoadOptions" is a null reference ( Nothing in Visual Basic) . |