Starts the transaction group with an assigned name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- transGroupName
- Type: System String
Name of the group. The name will be used only for a group that is assimilated at the end.
Return Value
If started successfully, this method returns TransactionStatus.Started.Remarks
A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group though. With such group nesting it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started. |