Obtains the IFC class name associated to the given element for the current export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The element.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
Return Value
The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.Remarks
IFC class names are affected by the user's entries in the mapping file set for a given export operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |