Definitions Class


A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class Definitions : IEnumerable<Definition>, 
	IDisposable
Visual Basic
Public Class Definitions _
	Implements IEnumerable(Of Definition), IDisposable
Visual C++
public ref class Definitions : IEnumerable<Definition^>, 
	IDisposable

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

See Also