FillPatternId Property


The id of fill pattern element of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public ElementId FillPatternId { get; set; }
Visual Basic
Public Property FillPatternId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ FillPatternId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

  • InvalidElementid represents no pattern, that means there would be nothing to be filled for elements colored based on this entry.
  • Only fill pattern elements whose fill pattern target is drafting is valid for color fill scheme.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also