Indicates whether the family can be converted to face host based.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- familyId
- Type: Autodesk.Revit.DB ElementId
The element id of the family.
Return Value
True if the family can be converted to face-based. Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host. Also, false is returned if the family does not belong to one of the following categories:- OST_CommunicationDevices
- OST_DataDevices
- OST_DuctTerminal
- OST_ElectricalEquipment
- OST_ElectricalFixtures
- OST_FireAlarmDevices
- OST_LightingDevices
- OST_LightingFixtures
- OST_MechanicalControlDevices
- OST_MechanicalEquipment
- OST_NurseCallDevices
- OST_PlumbingEquipment
- OST_PlumbingFixtures
- OST_SecurityDevices
- OST_Sprinklers
- OST_TelephoneDevices
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |