IsValidGeometry Method


Validates the input geometry to be stored in an externally tagged geometry object. Valid types of geometry are: Solid, Mesh, GeometryInstance, Point and Curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public static bool IsValidGeometry(
	GeometryObject geometry
)
Visual Basic
Public Shared Function IsValidGeometry ( _
	geometry As GeometryObject _
) As Boolean
Visual C++
public:
static bool IsValidGeometry(
	GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB GeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object passes the validation criteria.

See Also