SetFormatOptions Method


Sets the FormatOptions of the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void SetFormatOptions(
	FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
	formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
	FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB FormatOptions

Remarks

This method will set the FormatOptions if the scheme is by range, otherwise do nothing.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also