Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- trimExtendData
-
Type:
Autodesk.Revit.DB.Structure
RebarTrimExtendData
Use the members of this class to access the inputs and define any trim/extend actions to be taken for bars in the free form rebar.
Return Value
Returns true if the trim/extend was successful, false otherwise.Remarks
This function is called in the regeneration context when at least one data in trimExtendData parameter was changed. It is called immediately after GenerateCurves() and only if GenerateCurves() returns true.
If new constraints were created for start or end handle, a new regeneration will take place and the new constraints will become the rebar's actual constraints.
If new curves will be added by calling TrimExtendData.AddBarGeometry(), the existing curves in Rebar element will be replaced with these curves. It will not add curves to the existing ones.