GetSymbolGeometryId Method


Gets the SymbolGeometryId associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public SymbolGeometryId GetSymbolGeometryId()
Visual Basic
Public Function GetSymbolGeometryId As SymbolGeometryId
Visual C++
public:
SymbolGeometryId^ GetSymbolGeometryId()

Remarks

Use the strings returned by SymbolGeometryId.AsIdentifier(bool) to check if two nodes point to the same geometry of the symbol.

See Also