Represents the name of the reference for the top of this baluster or post.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Two pre-defined reference names can be obtained using [!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForHost()] or [!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForTopRail()] . The rest of valid reference names that are allowed to be used in the setter for TopReferenceName are the actual names of non-continuous rails [!:Autodesk::Revit::DB::Architecture::NonContinuousRailInfo::Name] in [!:Autodesk::Revit::DB::Architecture::NonContinuousRailStructure]
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: The name doesn't refer to a valid reference. |
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was null |